logo
down
shadow

Puppet include all repositories before installing package


Puppet include all repositories before installing package

By : user2956753
Date : November 22 2020, 03:03 PM
this one helps. The relationship between the classes is built, but this is insufficient, because relationships will not typically cross class include boundaries.
code :
contain postgresql
include postgresql
Yumrepo<| |> -> Class['database']
Class['repos::internal::blabla'] -> Class['database']


Share : facebook icon twitter icon
installing node.js via puppet; package not found

installing node.js via puppet; package not found


By : user3352469
Date : March 29 2020, 07:55 AM
I hope this helps . You need to add run the following first to pull in the pointers to the packages.
curl -sL https://deb.nodesource.com/setup | sudo bash -
Installing pear package using puppet

Installing pear package using puppet


By : Cheenue Yang
Date : March 29 2020, 07:55 AM
should help you out Managed to get it working using a combination of the example42/php module and a custom script:
code :
    include php
    php::pear::config { http_proxy:
             value => "http://xx.xx.xx.xx:xxxx",
    }
    exec { 'HTTP_Request2':
            command => '/usr/bin/pear install HTTP_Request2',
            unless  => '/usr/bin/pear info HTTP_Request2',
            require => Php::Pear::Config['http_proxy'],
    }
Puppet - while installing puppet dashboard, a rubygems(rake) dependency is blocking

Puppet - while installing puppet dashboard, a rubygems(rake) dependency is blocking


By : Goo Randil
Date : March 29 2020, 07:55 AM
like below fixes the issue I found the solution for this and now I am feeling silly to post this question since the answer to it is so simple.
I just went to this link https://rpmfind.net/linux/rpm2html/search.php?query=rubygem-rake and downloaded the Rake rpm, installed. and bam !! the puppet-Dashboard solves its dependency with the rake!
Puppet: How to reload enviroment when installing gem package - rbenv version is not active

Puppet: How to reload enviroment when installing gem package - rbenv version is not active


By : dias2502
Date : March 29 2020, 07:55 AM
it fixes the issue
So my question is: Is there a possibility to run the package provider in a new subshell? Or do I have to use another exec running gem install?
How to apply puppet manifests and modules WITHOUT installing Puppet RPM?

How to apply puppet manifests and modules WITHOUT installing Puppet RPM?


By : dharmendra dharmendr
Date : March 29 2020, 07:55 AM
Hope that helps Installing the relevant packages and then removing them would be by far the fastest and safest way to do what you wish. Maybe you can convince your customer that the cost in time for any other solution is not worth the money. Anyway, if packages are not an option, let's be innovative:
You do not have to install from packages, you can install puppet via ruby gems In the same way, you can use source tarballs
shadow
Privacy Policy - Terms - Contact Us © ourworld-yourmove.org