logo
down
shadow

Ruby: How to update to Ruby 2.1 in windows? (Installed 1.9.3 using Rails Installer)


Ruby: How to update to Ruby 2.1 in windows? (Installed 1.9.3 using Rails Installer)

By : user2951430
Date : November 18 2020, 11:13 AM
should help you out Quickest way would be to uninstall the previous version of rails installer, and installing with the new version of rails installer.
See https://stackoverflow.com/a/18083733/429758 & How to update ruby in windows for more on the same topic.
code :


Share : facebook icon twitter icon
What registry values are modified by the Ruby and Ruby on Rails Windows installer?

What registry values are modified by the Ruby and Ruby on Rails Windows installer?


By : Philippe
Date : March 29 2020, 07:55 AM
it helps some times It depends on the checkboxes you have selected.
Everything is in the source of the installer itself.
Gem installer error when setting up ruby on rails (Windows 7)

Gem installer error when setting up ruby on rails (Windows 7)


By : Víctor Roldán Betanc
Date : March 29 2020, 07:55 AM
This might help you Well, it turns out the problem was that the path to my Ruby install has spaces in it. This is apparently strongly disrecommended in a number of places, but the error message was unrelated enough that it took me a while to put two and two together.
Rails Installer - How to update just ruby from 1.9.x to 2.0 +?

Rails Installer - How to update just ruby from 1.9.x to 2.0 +?


By : javii_141
Date : March 29 2020, 07:55 AM
wish help you to fix your issue It is recommended you use RVM. Then you can switch between Ruby versions. You will still have to tell the Gemfile to use ruby '2.0.0'
Do I have to install Ruby from source to get Ruby 2.2.0 and Rails 4.2.0 installed on my windows machine?

Do I have to install Ruby from source to get Ruby 2.2.0 and Rails 4.2.0 installed on my windows machine?


By : devloper
Date : March 29 2020, 07:55 AM
Hope this helps The oldest available Ruby 2.2.x via RubyInstaller is 2.2.1 So, the answer to your question is, "Yes, you'll have to build from source."
But then again, v2.x of gem "rack" requires at least Ruby v2.2.2
code :
# Lock-in Lang and Framework:

ruby '2.2.6'
gem 'rails', '~> 4.2'
Windows, Ruby on rails bundle installer issue

Windows, Ruby on rails bundle installer issue


By : mgeorge
Date : March 29 2020, 07:55 AM
Hope this helps I've no idea what happened, but I've started getting this error: , Ran
code :
gem install rubygems-bundler
gem regenerate_binstubs
bundle install
Related Posts Related Posts :
  • Why can't I have ruby code and comments in Embedded Ruby?
  • Rails: How can I make an object available in all views?
  • Cannot enter simply form information into SQLite DB (Rails)
  • Rails - Retain form values on failed submission. Getting "First argument in form cannot contain nil or be empty&quo
  • How to handle STI and build related models automatically?
  • Suppress an error when saving a record in Rails
  • Rails AJAX reload the page. Why?
  • How to pass user attributes to action mailer
  • Custom Validator to Prevent an appointment from being scheduled too early in day?
  • Postgres Enable TCP/IP Connection
  • How do I avoid the circular argument reference warning in activesupport
  • Unable to push to heroku master because of rails/spring version error
  • deep nested routes in rails
  • Best approach to Users Profile Images in Rails App
  • RailsInstaller: Can I maintain the gem fold when re-installing a new version?
  • couldn't find file 'jquery-ui' i get this error even after having this file in my application.js
  • Ruby regex to split user and date text input
  • Tool like BetterErrors for JRuby?
  • redirect_to in action destroy ruby on rails
  • Where are the I18n.t link and reference paths?
  • Sending emails to multiple recipients in rails app
  • Rails, Devise, Sign up = write name in other Database
  • pass custom attribute on rspec factory_girl controller test
  • rails generate uses wrong version of Ruby
  • Duplicate Requests from a Browser
  • One action in Rails controller sends no data back
  • Local data (JSON) in Middleman inside a different path than /data
  • How to pass numbers in an array into a SQL statement
  • ActiveAdmin - Allow non-logged-in users to view but not edit resources
  • How to refactor this Model logic in Rails
  • :readonly key of belongs_to method doesn't work
  • Create a new view in directory
  • nested resources in devise
  • Yaml value with a leading `!`
  • Rails admin show username instead of User #5
  • Can't start WEBrick with Byebug on
  • Failing Rspec test of a FactoryGirl object
  • engine yard No application found matching remotes:
  • Rails 4 sessions cookie is not set
  • How do I flush a class method in Rails 4 using memcached?
  • AJAX form submitting in HTML rails 4
  • Using greater than or less than in a Rails Active Record query
  • Searching Post by Origin & Destination locations using Geokit-Rails
  • Deploying application to two different servers, with different production.rb contents
  • Spree with deface - Use deface to replace contents of block
  • I need to change date part of DateTime variable
  • Ruby on Rails 4 - Using Rake on Heroku
  • Ruby symbol setup
  • rescue inside an each_line code block
  • RoR/Squeel - How do I use Squeel::Nodes::Join/Predicates?
  • Using a different key name for an association attribute in rails api active model serializer
  • Running callbacks in rspec
  • Ruby on rails: wrong number of arguments (Devise and parsley-rails gems)
  • Query with Date.today returns two days
  • select all the values of the records belonging to a specific field of the database and save them in a array Active Recor
  • RSPEC test index action with before_action filter
  • Rails model columns and performance
  • keys and values from an ajax POST are all escaped
  • What is the formula for setting WEB_CONCURRENCY on heroku?
  • How to select objects based on their enum value and then sum another field belonging to the object collection in Rails
  • shadow
    Privacy Policy - Terms - Contact Us © ourworld-yourmove.org