logo
down
shadow

Grails: when does grails end to upload?


Grails: when does grails end to upload?

By : user2948024
Date : November 14 2020, 04:48 PM
it fixes the issue You need to mock request: This will give you list of all plugin which are used in the application (Will also include services, controller plugins)
code :
def applicationContext = WebApplicationContextUtils.getRequiredWebApplicationContext(servletContext)
def webRequest = grails.util.GrailsWebUtil.bindMockWebRequest(applicationContext)

webRequest.applicationContext.getBean('pluginManager').allPlugins.each {plugin ->
     println "${plugin.name} - ${plugin.version}"
}
logging - 2.2.2
core - 2.2.2
pluginConfig - 0.1.5
i18n - 2.2.2
urlMappings - 2.2.2
groovyPages - 2.2.2
controllers - 2.2.2
webappcore - 5.30.103
codenarc - 0.17
rendering - 0.4.3
buildInfo - 1.2.3


Share : facebook icon twitter icon
Ant call to grails fails with "[exec] Application is pre-Grails 0.5, please run: grails upgrade"

Ant call to grails fails with "[exec] Application is pre-Grails 0.5, please run: grails upgrade"


By : Aghiad Aldoukhna
Date : March 29 2020, 07:55 AM
With these it helps I finally found the solution to the problem, I don't know if this is the best way but it fixed my problem. So in the same target as the "exec" block I added a new "exec" block to invoke the upgrade on the grails.bat. So far so good, calling this command without parameters will generate a confirmation question whether to proceed with the requested operation - in ant this will create an infinite loop. In order to avoid this I added the "-f" parameter. The whole exec block:
code :
    <exec executable="cmd" dir="${parentDir}/${grails.appname}">
        <arg value="/c"/>
        <arg path="${env.GRAILS_HOME}/bin/grails.bat"/>
        <arg value="upgrade"/>
        <arg value="-force"/>
    </exec>
Grails 2.1.1 requires 'grails clean' before every 'grails run-app' -- command line only

Grails 2.1.1 requires 'grails clean' before every 'grails run-app' -- command line only


By : JPark
Date : March 29 2020, 07:55 AM
should help you out I would try running without reloading (which I think was grails -noreloading run-app) - does that address it?
If it does, we can dig a little deeper: it might be just the slcache that is being populated incorrectly, which can happen if using an up to date JDK with an older spring loaded. Between restarts (just using regular grails run-app) delete the .slcache - rm -rf ~/grails/2.1.3/.slcache rather than a grails clean. Does that make a difference?
Suggested library for grails 2.4.3 "org.grails:grails-datastore-test-support:1.0.1-grails-2.4" is not availabl

Suggested library for grails 2.4.3 "org.grails:grails-datastore-test-support:1.0.1-grails-2.4" is not availabl


By : S AP
Date : March 29 2020, 07:55 AM
I wish this help you Jeff Brown has fixed the issue named the dependency correctly, per the bug below. I verified that test "org.grails:grails-datastore-test-support:1.0.1-grails-2.4" now works!
I had the same issue I fixed it by changing the dependency to test "org.grails:datastore-test-support:1.0.1-grails-2.4" per http://search.maven.org/#artifactdetails|org.grails|datastore-test-support|1.0.1-grails-2.4|jar
Problems with grails.gorm.TestCriteriaBuilder when upgrading from Grails 2.4.4 to Grails 2.5.0

Problems with grails.gorm.TestCriteriaBuilder when upgrading from Grails 2.4.4 to Grails 2.5.0


By : user3853070
Date : March 29 2020, 07:55 AM
it helps some times I ran into the same exception when executing unit test after upgrading my application from 2.4.3 to 2.4.5. I manually added the package in the BuildConfig with test scope:
code :
runtime 'org.grails:grails-datastore-gorm:3.1.4.RELEASE'
Unindex maven repository https://repo.grails.org/grails/core in Intellij with Grails 3.0

Unindex maven repository https://repo.grails.org/grails/core in Intellij with Grails 3.0


By : dextract
Date : March 29 2020, 07:55 AM
this will help To resolve this problem i changed (the file is build.gradle) "https://repo.grails.org/grails/core/" for "http://repo.grails.org/grails/repo/"
So close and open your project again.
shadow
Privacy Policy - Terms - Contact Us © ourworld-yourmove.org